Electrical fault????

Post Reply
drago3108
BMW Enthusiast
Posts: 2
Joined: 05 Jun 2017, 10:00
Car model: bmw 318i , 2002, auto, estate, m46 engine
Location: kent

Electrical fault????

Post by drago3108 » 05 Jun 2017, 12:15

I have a 318i, 2002 automatic, e46 model with a n46 engine.. The car cut out and wouldn't restart although does turn over, the temperature gauge was all the way to the right showing overheating but the engine was still cold.. got it home and left it to the next day but still the same showing overheating and will not start (it happened two weeks ago as well and was' put right' by disconnecting the battery and touching the neg and live leads together to reset the ecu but this time doing the same has not cured the problem).. I have changed the engine coolant temperature sensor and the radiator outlet thermostatic switch and I have reset the ecu but still no difference... Any ideas please?:confused
Last edited by drago3108 on 06 Jun 2017, 17:40, edited 2 times in total.

User avatar
M60NJP
Site Owner
Posts: 23390
Joined: 12 Oct 2011, 13:22
Car model: 135i M Sport
Isetta 300
Location: Bucks
Location: Buckinghamshire
Contact:

Re: Temperature sensor fault????

Post by M60NJP » 05 Jun 2017, 12:18

Other than extremes, the coolant temperature alone won't affect starting.

It reads like you have an electrical issue if it won't turn over at all.

tannan
BMW Enthusiast
Posts: 68
Joined: 14 Apr 2017, 15:11
Car model: 2013 bmw 320d f30
Location: Liverpool
Location: Liverpool

Re: Temperature sensor fault????

Post by tannan » 05 Jun 2017, 22:27

If it's an auto dose it need to be in park to start as the old auto cars some time you had to mess around with the gear selector to get the engine to start prob not the case hear but worth a go

Post Reply

Return to “Electrical”